Whilst our app is compatible with most devices, there are some minimum specifications to ensure that our customers receive the Perlego reading experience they expect.

This is also why we decided to stop supporting iOS 12 (after a lot of deliberation) as we found that app performance was not to the standard we aim for.

Android specifications:

  • Version 8 (Oreo) and above

  • Minimum 1.5GB RAM

iOS specifications:

  • Version 13 and above

  • Minimum 1.5GB RAM

Older devices that were using Perlego before these compatibility changes will still have access but won't experience our latest updates such as the removal of Favourites with the new personal library experience.

We always recommend being on the latest software to help you have the best experience you can on Perlego.

If you need anything else or have any questions, then feel free to get in touch with our support team on livechat or at [email protected] 😊

Did this answer your question?